Go Back   5Series.net - Forums > E60 5 Series (2004 - 2010) > E60 Discussion
Sign in using an external account
Register Forgot Password?

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-30-2013, 03:39 PM   #1
New Members
 
Join Date: Jul 2013
Location: san antonio
Posts: 1
Default Head unit not programmed correctly

I just bought a 545i and notice when I turn on the car the head unit reads: HEAD UNIT NOT PROGRAMMED CORRECTLY! What should I do to get it working properly. Other than that, car runs great. Any help will be greatly appreciated,

Thanks
black knight is offline   Reply With Quote
Old 07-30-2013, 04:17 PM   #2
Contributors
 
Join Date: Sep 2007
Location: Encino, CA
Posts: 1,712
Default

Was it doing that before you bought it? Sounds like somebody attempted to code it and botched up somewhere. Is it a Nav or non-Nav equipped car (easy way to tell - single disk slot or dual disk slots)?
__________________
04 545i


//My Photo Albums
advancedlogic is offline   Reply With Quote
Old 07-30-2013, 06:09 PM   #3
New Members
 
Join Date: Sep 2012
Location: Greensboro, NC (USA)
Posts: 246
Default

I'd like a picture of that one.. new one on me
ncsugrad2006 is offline   Reply With Quote
Old 07-31-2013, 07:25 AM   #4
Members
 
infin8's Avatar
 
Join Date: Jun 2011
Location: Phoenix, AZ
Posts: 245
Default

Quote:
Originally Posted by black knight View Post
I just bought a 545i and notice when I turn on the car the head unit reads: HEAD UNIT NOT PROGRAMMED CORRECTLY! What should I do to get it working properly. Other than that, car runs great. Any help will be greatly appreciated,

Thanks
Did you buy it sight unseen? I would have asked the seller questions about this error before I purchased it, if maybe he tried coding something and failed. I would get as much info as possible about the cause of the error so you know where to begin trying to fix it. Otherwise you're looking for a needle in a haystack. Are you still in contact with the seller? I would call him up...
infin8 is offline   Reply With Quote
Old 07-31-2013, 03:59 PM   #5
Members
Senior Members
 
Join Date: Jan 2012
Location: Dayton, OH
Posts: 461
Default

Just get someone with a optical device (OPS, etc) to reprogram or just take to the dealer and have the entire car updated.
Gee_115 is offline   Reply With Quote
Old 08-31-2013, 07:27 PM   #6
Members
 
Join Date: Mar 2010
Location: dallas
Posts: 2
Default

there is a relay in the trunk under the spare tire. I spilled a bucket of water in the trunk one day {dont ask how ] and that relay shorted out. That relay controls cd/radio/head-up dispay. For 100$ you can get a new relay from a salvage dealer.When changed the relay, everything working now but at start up it says head unit not......
chrisgo is offline   Reply With Quote
Old 08-31-2013, 07:38 PM   #7
Contributors
 
Join Date: Sep 2007
Location: Encino, CA
Posts: 1,712
Default

Quote:
Originally Posted by chrisgo View Post
there is a relay in the trunk under the spare tire. I spilled a bucket of water in the trunk one day {dont ask how ] and that relay shorted out. That relay controls cd/radio/head-up dispay. For 100$ you can get a new relay from a salvage dealer.When changed the relay, everything working now but at start up it says head unit not......
Ya that's the infamous MPM - Micro Power (control) Module, prone to liquid damage, along with the PDC. I had a liquid run-in with it years ago and picked up a new one and plugged it in. The head unit was fine. Quite a few others have had MPM failures and no head unit issues. It may be coincidental, or perhaps you encountered a short/surge that wiped your unit's programming.
__________________
04 545i


//My Photo Albums
advancedlogic is offline   Reply With Quote
Old 09-01-2013, 04:56 PM   #8
Contributors
 
Join Date: Mar 2010
Location: Los Angeles, CA
Posts: 2,977
Default

Hmmmm....curious as to if the OP resolved this. No response in over a month?
balbs is offline   Reply With Quote
Old 09-01-2013, 04:56 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:33 PM.


All content Copyright 2012 by Internet Brands, Inc.

SEO by vBSEO ©2010, Crawlability, Inc.